WordPress升级到2.8遇到的问题

上周末的时候看到后台提示可以升级到wordpress2.8,我就简单做了一个文章导出,之后在线升级到2.8,我之前的版本是2.7.1,提示升级成功,但转到“控制板”之后,提示错误

Allowed memory size of  xxxxxxxxx bytes exhausted

2.8难道有问题,我可没有做完整的备份,2.8的数据库有改动,如果2.8真的有问题就麻烦了,这个错误是说PHP分配内存太小,只要修改php.ini就可以,但我现在用的是虚拟主机,不能修改php.ini的,还是网上搜一下吧,很快,找到了答案,只要在wp-settings.php里修改为

define(‘WP_MEMORY_LIMIT’, ’64M’);

就可以了(以前是32M,如果不行可以继续改大)。

Memory解决了,但后台还是提示有新版本2.8,要我升级,我不是已经升级成功了吗,奇怪,后来查了一下,由于我用的是中文版,所以在wp-includes/version.php里增加一行

$wp_local_package = ‘zh_CN’;

就不会再提示有新版本了。